Nodes stuck at block 6094 and do not sync any more


#1

After ussue with stuck network at block 6094 all my node don`t want to sync.
Even after i delete all files chain synced only to block 6094. But explorer and API display 6321 already…
This files was removed:
epochinfo-00001-log
state-00001-log
zilliqa-00001-log
and folders:
persistence
And it is not help.

It looks like devs excluded 1 sharding structre, because now only 2 sharding exist…


#2

6321 is just a story , in reality all nodes are stuck , issues are present since 36 h ago when rewards stopped being allocated , after that all broke down , it was stuck at 6000 for a period of good hours and now at 6094. I have 12 nodes and all of them are the same , different datacenters and so …

I like that the devs are keeping the quiet , nobody is telling us anything … this really really rise up good question marks when it comes to the credibility of this entire project


#3

Maybe we need new dsnodes.xml file where be correct nodes?
because with current state nothing not work!


#4

it is not from us , I have removed the docker image and downloaded again the configuration files , and got all new again as from the mining wiki still the same issues.

Also , if a change in config was needed I would expect in a normal world that a announcement be placed for everybody to see and act on it but again , you can look all around on redit , here and so on , not even one member of the zilliqa team provided any comment or update


#5

Make your step again. I see that configuration.tar.gz is updated today.
I remove docker image and make all like on wike page.
Now chain synced!

Interested that Wiki say: Processing of the upgrade mechanism (as there are no forks in pBFT).
But if there no forks, so what then was today as not fork…


#6

Correct, the config and zilliqa docker image changed since I tried

Would have been nice to make people aware of this changes still


#7

I just wonder since the block number is now 500 blocks higher than before we got stuck on block 6094 then who was mining (and receiving rewards) during all that time? Hackers who made common miners stuck on block 6094 on purpose?

Also this is very stupid to place multipliers IPs and pubkeys in one giant constants.xml file while DSnodes is a separate dsnodes.xml file. Also name constants.xml suggests constants, but contents is variable. So stupid… was it planned fuckup?


#8

After today update I see that stopped writing logs about the reward, ds buckup or shard buckup like it was early.
This was not convenient because you can not see how many rewards received…

P.S.Looks like network work good after update.


#9

You wrote: “stopped writing logs about the reward, ds buckup or shard buckup like it was early”. Is it still the case?


#10

In 1 node logs writing about reward… in other i don’t see reward notices
but actually the reward is given for both nodes


#11

What do you mean by showing those 2 screenshots? Are those 2 coming from 2 GPU rigs mining for 1 CPU node or 2 CPU nodes? Is this ZilSwitcher some custom app? I remember ZilSwitcher (https://github.com/DanSoQt/ZilSwitcher) not having rewards display.

By logs i mean Zilliqa node logs stored on CPU node.


#12

each node have rig for mining when pow phase enabled.
1 node have in logs recordes:
I am shard backup
REWARD…
other node not have any records about this, but both nodes get reward.
i post this screenshots where you can see that any case both node rewarded regardless of whether there are recordes in the log or not…
p.s. yes it is custom app.


#13

Interesting. Is the config of both nodes the same? constants.xml is the same? Are you using docker images or native zilliqa client?

There are holes in documentation for zilminer and zilliqa node. Does starting non cuda docker zilliqa node (launch_docker.sh without --cuda) do any mining at all during PoW phase?

Does leaving FULL_DATASET_MINE set to TRUE with CUDA and OpenCL set to false in Zilliqa client make it do CPU mining or idling during PoW phase?

Did you wrote the app yourself?


#14

constants.xml is the same for both nodes. I mine without use cpu, only GPU rig when pow phase enabled. All maded according to the Wiki page.

yes, the application is written by me because zilminer does not work the flag --pow-end correctly.
It is simple switcher that close current secondary miner at block 99 and start zil miner until block 01 comes or for 120s (POW phase 60s). After that switcher close zilminer and open secondary miner again.


#15

What do you mean by “does not work the flag --pow-end correctly”?

If you wrote this app then what are you using to get info about rewards if the node does not produce proper logs for you?


#16

zilminer with flag --pow-end should start .bat file after POW phase ended. But this is not happening…

To get last reward i use zilliqa API. I remember current balance before block 00 and after POW phase end i made request to API again and get new balance. The difference between balances and there is a reward.
Everything is very simple )


#17

Strange, for me zilminer starts --pow-end script when PoW phase ended.

Your app has some rounding problems i think (do you use floating point?).


#18

yes, balance is rounding to 8 digit after dot.
zilminer starts --pow-end does not work correct for anyone … Rather, it works … but it open a bat file after a very-very long time. rather even just by timeout


#19

Do you mean this or something worse?


#20

Exactly this i mean.