GPU mining fails - `The software is not build with CUDA`

#1

Hi! I get an interesting error when I try to mine with NVidia GPU (by running ./launch_docker.sh --cuda). Trying to interpret the logs I’d say the cuda docker image wasn’t compiled with a cuda support. Is this possible?

p.s. I changed the 2 values (FULL_DATASET_MINE & CUDA_GPU_MINE) in constants.xml to true

[INFO][ 1810][19-02-02T15:57:41.500][ibNode/Node.cpp:1583][SetState            ] [Epoch 1] Node State = POW_SUBMISSION
[FATA]
	*******	 EXIT trigger caused by LOG(FATAL) entry: 
	"[ 1810][19-02-02T15:57:42.039][c/libPOW/pow.cpp:783][InitCUDA            ] The software is not build with CUDA. Please enable the CUDA build option and build software again
*******	STACKDUMP *******
	stack dump [1]  zilliqa() [0xcdca9b]
	stack dump [2]  zilliqa() [0x8afa52]
	stack dump [3]  zilliqa() [0x8b0348]
	stack dump [4]  zilliqa() [0x8b05ba]
	stack dump [5]  zilliqa() [0x761dd4]
	stack dump [6]  zilliqa() [0x762101]
	stack dump [7]  zilliqa() [0x4c87da]
	stack dump [8]  /usr/lib/x86_64-linux-gnu/libstdc++.so.6+0xb8c80 [0x7fa435186c80]
	stack dump [9]  /lib/x86_64-linux-gnu/libpthread.so.0+0x76ba [0x7fa4349996ba]
	stack dump [10]  /lib/x86_64-linux-gnu/libc.so.6clone+0x6d [0x7fa4346cf41d]

Exiting after fatal event  (FATAL). Fatal type:  SIGABRT
Log content flushed sucessfully to sink

"g3log g3FileSink shutdown at: 15:57:42 040062
0 Likes

#2

We are aware of this issue, will be working on it.

0 Likes

#3

Thanks! Is there something I can do meanwhile? E.g. is Mining with a CPU-only viable? And one final thing - where should I check for updated to know (and test) when the issue was fixed?
Thanks again!

0 Likes

#4

Does gpu actually mine in docker with --cuda when this parameter is set to false? Or does it sit idle?

0 Likes

#5

@noncoder000
In my case - I couldn’t see anything in the logs after the quote in my first comment. If you mean the load on the GPU itself (e.g. from a third party monitor tool) - no it was working as normal - it was idle.

0 Likes

#6

The current workaround is Option 2 in the wiki, mining with docker build but remotely. So you have a CPU running consensus, and a separate GPU rigs doing PoW when it is time to do so. (Zilminer does this automatically)

0 Likes

#7

Thanks @snowsledge ! I think I managed to setup Zilminer already. At least it finds the GPU :slight_smile: I am not sure it does any work yet but I’ll use other more appropriate threads if needed.
image

0 Likes

#8

What is the real solution aka not a workaround with remote setup?

0 Likes

#9

Wait for the next network upgrade in late Feb.

0 Likes

archived #10
0 Likes