CPU mining during PoW phase

#1

There are holes in documentation for zilminer and zilliqa node and so i need to ask:

Does starting non cuda docker zilliqa node (launch_docker.sh without --cuda) do any mining at all during PoW phase? Does it use CPU during PoW phase?

Does leaving FULL_DATASET_MINE set to TRUE while leaving CUDA_GPU_MINE and OpenCL_GPU_MINE set to FALSE in Zilliqa client make it do CPU mining or idling during PoW phase?

UPDATE: Really? Developers don’t care about such questions being answered?

0 Likes

#2

You may want to read the documentation again to understand your needs.

CPU mining is the default option when you set FULL_DATASET_MINE to true.

0 Likes

#3

I have already read the documentation.

What i need to know is if the CPU mining gets disabled when CUDA_GPU_MINE is enabled.

I already saw in the log that enabling GETWORK server causes FULL_DATASET_MINE to become disabled. But does enabling CUDA_GPU_MINE have the same effect on FULL_DATASET_MINE?

How much CPU mining is slower than GPU mining?

Where can I check CPU mining stats of the Zilliqa node?

0 Likes

#4

The docker image for CUDA is built for only CUDA GPU mining. (meaning ./build.sh cuda)
Hence, when you use the CUDA docker image, your CPU will not be mining.

The parameter FULL_DATASET_MINE must be set to true for using either the CPU docker image or the CUDA docker image.

0 Likes

#5

Are there any stats available for internal CPU/GPU mining in Zilliqa client?

I am using docker version. Does native version give more info?

0 Likes

#6

So if the parameter FULL_DATASET_MINE must be set to true and in the same time you wrote to your DOCUMENTATION regarding multi node multi scenario that FULL_DATASET_MINE must be set to false YOU or your colleague should FIX your DOCUMENTATION because it is full of discrepancies!
ME and all other people are not obligated to REVERSE ENGINEER this mesh of very new and very old version of software and non working installation guides and unknown dependencies in your node topology no one is paying that!!! Your documentation is unsufficient and not complete!

0 Likes

#7

Hi there,

I am quite confused by your scenario. Are you trying Option 2 instead of Option 1? If that is the case, the documentation does clearly state that FULL_DATASET_MINE must be set to false.

0 Likes

#8

This in your Documentation written as option 2 - Multi GPU,CPU,PROXY configuration
and at step 3 you are pointing [Mining guide wiki) to Option 1

Step 3. Download and setup the Zilliqa client on all your CPU nodes

NOTE : Zilliqa client is only supported on Ubuntu 16.04 OS.
You can follow the Mining guide wiki for either docker or native build to setup your Zilliqa clients on all your CPUs.

Anyway i have few nodes with or without FULL DATA SET and didn’t saw a reward to none of them for 30hours.

0 Likes

#9

The instructions for the parameters for CPU nodes are shown in Step 3, and the link does not point to Option 1 in the Official Mining wiki:

For all your CPU nodes, you will have to edit the constants.xml file in your configuration files for the following parameters before launching:

  • Set REMOTE_MINE to true .
  • Set MINING_PROXY_URL to the URL of your mining proxy server. (e.g. http://127.0.0.1:4202/api )
  • Set the other mining parameters to false .
<CUDA_GPU_MINE>false</CUDA_GPU_MINE>
<FULL_DATASET_MINE>false</FULL_DATASET_MINE>
<OPENCL_GPU_MINE>false</OPENCL_GPU_MINE>
<GETWORK_SERVER_MINE>false</GETWORK_SERVER_MINE>

Do note that Mining proxy server is a community project. It is not part of the official supported mining softwares. If you have some issues with the documentation created by the community, you can do a suggestion improve it for other Miners.

0 Likes

#10

Yes the link does not point to Option 1 but there is not option 2 also . I mean it is not very obvious that configuration for for single node topology should relate on 100% to multi node topology. Mining proxy is fine but somehow for 30 hours i didn’t saw a single attempt for connection to it .

0 Likes

#11

Does the Zilliqa client (launch.docker.sh with NO --cuda) do any mining at all? I dont mean TX signing in microblocks. I mean if it does any mining during PoW phase. Does it do any mining during PoW phase using CPU or not?

0 Likes

#12

Yes, it does. If you launch without the --cuda flag, it will simply mine with your CPU during the PoW window.

0 Likes

#13

Does it still do CPU mining if you enable GETWORK_SERVER_MINE on that node?

In other words does GETWORK_SERVER_MINE set o TRUE stops CPU mining?

UPDATE: Oh come on, surely you know the answer!

0 Likes

#14

Yes, when you set GETWORK_SERVER_MINE to true, CPU mining will stop as you triggered the remote mining flag.

0 Likes