Constants.xml and node GPU mining


#1

I’m going to use CUDA mining including in the mainnet node. According to the wiki, you just get to modify this directive with the number of GPU you wanna use :

<GPU_TO_USE>0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11</GPU_TO_USE>

But… nothing about this one :

<CUDA_GPU_MINE>false</CUDA_GPU_MINE>

Don’t we have to change it to true ? Any documentation on all the constants.xml directives ?


#2

Tried using :

<CUDA_GPU_MINE>true</CUDA_GPU_MINE>

Which gives me (docker image) :

[INFO][ 1810][19-02-01T01:13:48.689][ibNode/Node.cpp:1583][SetState            ] [Epoch 1] Node State = POW_SUBMISSION
[FATA]
        *******  EXIT trigger caused by LOG(FATAL) entry:
        "[ 1810][19-02-01T01:13:49.345][c/libPOW/pow.cpp:783][InitCUDA            ] The software is not build with CUDA. Please enable the CUDA build option and build software again
******* STACKDUMP *******
        stack dump [1]  zilliqa() [0xcdca9b]
        stack dump [2]  zilliqa() [0x8afa52]
        stack dump [3]  zilliqa() [0x8b0348]
        stack dump [4]  zilliqa() [0x8b05ba]
        stack dump [5]  zilliqa() [0x761dd4]
        stack dump [6]  zilliqa() [0x762101]
        stack dump [7]  zilliqa() [0x4c87da]
        stack dump [8]  /usr/lib/x86_64-linux-gnu/libstdc++.so.6+0xb8c80 [0x7f4b0746fc80]
        stack dump [9]  /lib/x86_64-linux-gnu/libpthread.so.0+0x76ba [0x7f4b06c826ba]
        stack dump [10]  /lib/x86_64-linux-gnu/libc.so.6clone+0x6d [0x7f4b069b841d]

Exiting after fatal event  (FATAL). Fatal type:  SIGABRT
Log content flushed sucessfully to sink

"g3log g3FileSink shutdown at: 01:13:49 345888

Do I have to download a specific image with CUDA enabled ? (and yes, I used the --cuda option)


#3

In theory, the launch_docker.sh script should do that for you. At least that’s what I get from reading it. E.g. it normally uses the zilliqa/zilliqa:v4.0.1 image, but if you provide --cuda it appends -cuda to the image name so it would be zilliqa/zilliqa:v4.0.1-cuda. Also, it would run docker with --runtime=nvidia.

I get the exact same error as you - The software is not build with CUDA. - and I made a separate thread for it here. If I have any updates, I’ll try to post here as well :slight_smile:


#4

found the same, opened a github issue https://github.com/Zilliqa/Zilliqa/issues/1379